読者です 読者をやめる 読者になる 読者になる

PHP のモジュール GD がインストールされていません

ownCloudにブラウザからアクセスしたら、エラーメッセージが表示されてログインできない状態になっていたので対処方法を紹介します。

エラーメッセージ
PHP のモジュール GD がインストールされていません。
サーバー管理者にモジュールのインストールを依頼してください。

エラーメッセージに書いてある通り、GD(php-gd)がインストールされていませんでした。なので、GDをインストールします。

 

GD(php-gd)をインストール

私のサーバでは、PHP5.5を使っているのでYumリポジトリ「remi-php55」を指定して「php-gd」をインストールします。

# yum --enablerepo=remi-php55 install -y php-gd
読み込んだプラグイン:fastestmirror
インストール処理の設定をしています
Loading mirror speeds from cached hostfile
 * base: ftp.iij.ad.jp
 * extras: ftp.iij.ad.jp
 * remi-php55: remi.kazukioishi.net
 * updates: ftp.iij.ad.jp
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> Package php-gd.x86_64 0:5.5.21-1.el6.remi will be インストール
--> 依存性の処理をしています: gd-last(x86-64) >= 2.1.0-3 のパッケージ: php-gd-5.5.21-1.el6.remi.x86_64
--> 依存性の処理をしています: libvpx.so.1()(64bit) のパッケージ: php-gd-5.5.21-1.el6.remi.x86_64
--> 依存性の処理をしています: libt1.so.5()(64bit) のパッケージ: php-gd-5.5.21-1.el6.remi.x86_64
--> 依存性の処理をしています: libpng12.so.0()(64bit) のパッケージ: php-gd-5.5.21-1.el6.remi.x86_64
--> 依存性の処理をしています: libjpeg.so.62()(64bit) のパッケージ: php-gd-5.5.21-1.el6.remi.x86_64
--> 依存性の処理をしています: libgd.so.3()(64bit) のパッケージ: php-gd-5.5.21-1.el6.remi.x86_64
--> 依存性の処理をしています: libfreetype.so.6()(64bit) のパッケージ: php-gd-5.5.21-1.el6.remi.x86_64
--> 依存性の処理をしています: libXpm.so.4()(64bit) のパッケージ: php-gd-5.5.21-1.el6.remi.x86_64
--> 依存性の処理をしています: libX11.so.6()(64bit) のパッケージ: php-gd-5.5.21-1.el6.remi.x86_64
--> トランザクションの確認を実行しています。
---> Package freetype.x86_64 0:2.3.11-14.el6_3.1 will be インストール
---> Package libX11.x86_64 0:1.6.0-2.2.el6 will be インストール
--> 依存性の処理をしています: libX11-common = 1.6.0-2.2.el6 のパッケージ: libX11-1.6.0-2.2.el6.x86_64
--> 依存性の処理をしています: libxcb.so.1()(64bit) のパッケージ: libX11-1.6.0-2.2.el6.x86_64
---> Package libXpm.x86_64 0:3.5.10-2.el6 will be インストール
---> Package libjpeg-turbo.x86_64 0:1.2.1-3.el6_5 will be インストール
---> Package libpng.x86_64 2:1.2.49-1.el6_2 will be インストール
---> Package libvpx.x86_64 0:1.3.0-5.el6_5 will be インストール
---> Package php-gd.x86_64 0:5.5.21-1.el6.remi will be インストール
--> 依存性の処理をしています: gd-last(x86-64) >= 2.1.0-3 のパッケージ: php-gd-5.5.21-1.el6.remi.x86_64
--> 依存性の処理をしています: libgd.so.3()(64bit) のパッケージ: php-gd-5.5.21-1.el6.remi.x86_64
---> Package t1lib.x86_64 0:5.1.2-6.el6_2.1 will be インストール
--> トランザクションの確認を実行しています。
---> Package libX11-common.noarch 0:1.6.0-2.2.el6 will be インストール
---> Package libxcb.x86_64 0:1.9.1-2.el6 will be インストール
--> 依存性の処理をしています: libXau.so.6()(64bit) のパッケージ: libxcb-1.9.1-2.el6.x86_64
---> Package php-gd.x86_64 0:5.5.21-1.el6.remi will be インストール
--> 依存性の処理をしています: gd-last(x86-64) >= 2.1.0-3 のパッケージ: php-gd-5.5.21-1.el6.remi.x86_64
--> 依存性の処理をしています: libgd.so.3()(64bit) のパッケージ: php-gd-5.5.21-1.el6.remi.x86_64
--> トランザクションの確認を実行しています。
---> Package libXau.x86_64 0:1.0.6-4.el6 will be インストール
---> Package php-gd.x86_64 0:5.5.21-1.el6.remi will be インストール
--> 依存性の処理をしています: gd-last(x86-64) >= 2.1.0-3 のパッケージ: php-gd-5.5.21-1.el6.remi.x86_64
--> 依存性の処理をしています: libgd.so.3()(64bit) のパッケージ: php-gd-5.5.21-1.el6.remi.x86_64
--> 依存性解決を終了しました。
エラー: パッケージ: php-gd-5.5.21-1.el6.remi.x86_64 (remi-php55)
             要求: libgd.so.3()(64bit)
エラー: パッケージ: php-gd-5.5.21-1.el6.remi.x86_64 (remi-php55)
             要求: gd-last(x86-64) >= 2.1.0-3
 問題を回避するために --skip-broken を用いることができません
 これらを試行できます: rpm -Va --nofiles --nodigest

php-gdのインストールでもエラーメッセージが出力されてしまいました。

gd-lastとの依存関係が解決できないと書いてあるので、gd-lastをインストールします。

 

gd-lastをインストール

gd-lastは、指定したYumリポジトリ「remi-php55」に無いようなので、指定するYumリポジトリを「remi」に変えてインストールします。

# yum --enablerepo=remi install gd-last

 

あらためて、GD(php-gd)をインストール

GD(php-gd)をインストールします。

# yum --enablerepo=remi-php55 install -y php-gd

エラーメッセージが表示されることもなく、無事インストールが完了しました。