`block in setup': You have already activated faye-websocket 0.9.2, but your Gemfile requires faye-websocket 0.7.5. Prepending `bundle exec` to your command may solve this. (Gem::LoadError)

Rails server の起動に失敗したので、対処方法をメモおく。

 

作業環境
- OS: CentOS Linux release 7.1.1503 (Core)
- Ruby: 2.2.0
- Rails: 4.2.3
- gem: 2.4.8

 

ERROR
# volt server
WARN: Unresolved specs during Gem::Specification.reset:
      rack (~> 1.5.0)
      sprockets-sass (~> 1.0.0)
      rb-fsevent (>= 0.9.3)
      ffi (>= 0.5.0)
      sprockets (< 3.0.0, >= 2.2.3)
      websocket-driver (>= 0.5.1)
WARN: Clearing out unresolved specs.
Please report a bug if this causes problems.
/root/.rbenv/versions/2.2.0/lib/ruby/gems/2.2.0/gems/bundler-1.10.6/lib/bundler/runtime.rb:34:in `block in setup': You have already activated faye-websocket 0.9.2, but your Gemfile requires faye-websocket 0.7.5. Prepending `bundle exec` to your command may solve this. (Gem::LoadError)
        from /root/.rbenv/versions/2.2.0/lib/ruby/gems/2.2.0/gems/bundler-1.10.6/lib/bundler/runtime.rb:19:in `setup'
        from /root/.rbenv/versions/2.2.0/lib/ruby/gems/2.2.0/gems/bundler-1.10.6/lib/bundler.rb:127:in `setup'
        from /root/.rbenv/versions/2.2.0/lib/ruby/gems/2.2.0/gems/bundler-1.10.6/lib/bundler/setup.rb:8:in `'
        from /root/.rbenv/versions/2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:69:in `require'
        from /root/.rbenv/versions/2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:69:in `require'
        from /root/.rbenv/versions/2.2.0/lib/ruby/gems/2.2.0/gems/volt-0.9.4/lib/volt/cli.rb:2:in `'
        from /root/.rbenv/versions/2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:69:in `require'
        from /root/.rbenv/versions/2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:69:in `require'
        from /root/.rbenv/versions/2.2.0/lib/ruby/gems/2.2.0/gems/volt-0.9.4/bin/volt:4:in `'
        from /root/.rbenv/versions/2.2.0/bin/volt:23:in `load'
        from /root/.rbenv/versions/2.2.0/bin/volt:23:in `
'

 

 

対処方法
# gem cleanup

 

 

以上、終わり